Post a new topic
    3 Replies Latest reply on May 4, 2009 2:14 PM by Blaque

    My disc drives not working

    amspcs Ranger
      I'm hoping this has a simple solution and someone out there knows what it is because I certainly don't.

      I can't seem to use either of the two disc drives (one RW, one read-only). Getting a message that
      computer doesn't recognize either of them, which I have confirmed by checking out My Computer in both reguar and safe modes---neither drive showing up. I have the original CD containng the drives, but that doesn't do me much good if the drive isn't working. Can anybody suggest a fix or a diagnostic website of some kind in which I an correct the problem? Both drive doors open up and the diode glows, so I know they're connected, just not doing anything. Thanks in advance.
        • Re: My disc drives not working
          Generation4 Adventurer

          Are you having the issue with an internal disk drive (located with your computer/laptop) or external drive? If it's an external drive - maybe the cable is loose? If it's internal - have you tried rebooting your computer? Also, do you currently have a CD in the drive? Or is it empty?
            • Re: My disc drives not working
              amspcs Ranger
              Two internal drives. Have tried rebooting in safe mode and regular, with and without disc inserted.
              No response. I suspect the problem is the driver is corrupted. I have the original CD, but can't use it due
              to disc drive not working. So perhaps I could re-download the needed driver over the internet.

              Which leads to two new questions:
              a.) How do I find out what model, version setc of the drives I have so I can download the correct driver
              b.) Where would I find the drive on the internet so I can download it?

            • Re: My disc drives not working
              Blaque Adventurer

              It's a common problem with XP try


              Click Start, and then click Run.
              In the Open box, type regedit, and then click OK.
              In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}
              In the right pane, click UpperFilters. Note You may also see an UpperFilters.bak registry entry. You do not have to remove that entry. Click UpperFilters only. If you do not see the UpperFilters registry entry, you still might have to remove the LowerFilters registry entry. To do this, go to step 7.
              On the Edit menu, click Delete.
              When you are prompted to confirm the deletion, click Yes.
              In the right pane, click LowerFilters. Note If you do not see the LowerFilters registry entry, unfortunately this content cannot help you any further. On the Edit menu, click Delete.
              When you are prompted to confirm the deletion, click Yes.
              Exit Registry Editor.
              Restart the computer.


              Microsoft also has a free to that will fix your problem

              Good luck